Smite Matchmaking Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Nov 12, 2021 - 09:55 EST
Monitoring
Logins and matchmaking have resumed for #SMITE. We will continue to monitor.
Posted Nov 12, 2021 - 09:18 EST
Investigating
We are investigating an issue that is affecting matchmaking services in #SMITE. Logins have been limited while we work to resolve this issue.
Posted Nov 12, 2021 - 09:09 EST
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic).