Hand of the Gods Emergency Restart.
Incident Report for Hi-Rez Studios, Inc
Resolved
Emergency Restart of Hand of the Gods is now completed.
Posted Dec 04, 2019 - 13:52 EST
Investigating
We are currently investigating the issue.
Posted Dec 04, 2019 - 13:38 EST
This incident affected: Hand of the Gods (Hand of the Gods PC, Hand of the Gods PS4, Hand of the Gods Xbox).