Rogue Company Xbox Login issue.
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Dec 16, 2020 - 23:32 EST
Update
We are continuing to investigate this issue.
Posted Dec 16, 2020 - 15:36 EST
Investigating
Rogue Company for Xbox players will get a "Mismatch" error upon login. We apologize for the inconvenience this has caused.
Posted Dec 16, 2020 - 12:40 EST
This incident affected: Rogue Company (Rogue Company Xbox).