Tribes Ascend Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
Restart of Tribes Ascend has been completed
Posted Dec 04, 2019 - 15:13 EST
Investigating
We are currently investigating this issue.
Posted Dec 04, 2019 - 13:48 EST
This incident affected: Tribes Ascend (Tribes Ascend PC).