Paladins PC Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 month ago. Jul 15, 2018 - 07:09 EDT
Monitoring
Logins are resumed on Paladins PC, we are monitoring the environment at this time.
Posted about 1 month ago. Jul 15, 2018 - 07:00 EDT
Investigating
We are currently looking into issues with logons for Paladins PC.
Posted about 1 month ago. Jul 15, 2018 - 06:55 EDT
This incident affected: Paladins (Paladins PC).