Rogue Company Crossplay Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This #RogueCompany incident has been resolved.
Posted Oct 12, 2021 - 09:46 EDT
Monitoring
This #RogueCompany emergency restart has been completed, and we are monitoring the results. Again, we apologize for the inconvenience.
Posted Oct 12, 2021 - 09:18 EDT
Identified
We are performing an emergency maintenance for #RogueCompany at this time. We will update accordingly and apologize for the inconvenience.
Posted Oct 12, 2021 - 08:31 EDT
This incident affected: Rogue Company (Rogue Company PC, Rogue Company PS4, Rogue Company Xbox, Rogue Company Switch, Rogue Company Epic).