Realm Royale Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Dec 04, 2019 - 13:53 EST
Investigating
We are currently investigating the issue.
Posted Dec 04, 2019 - 13:26 EST
This incident affected: Realm Royale (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch).