HiRez Games - Issue with Steam logins
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Mar 11, 2021 - 16:27 EST
Identified
This issue has been identified.
Posted Mar 11, 2021 - 14:59 EST
This incident affected: Realm Royale (Realm Royale PC), SMITE (SMITE PC), and Paladins (Paladins PC).