Live Services Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted May 03, 2020 - 05:42 EDT
Monitoring
All games are back online. Players may be met with a brief login queue on launch. We will continue to monitor in the meantime.
Posted May 02, 2020 - 22:18 EDT
Investigating
We are currently investigating an issue that is affecting some of our live services
Posted May 02, 2020 - 21:17 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch), Realm Royale (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch), and Paladins (Paladins PC, Paladins PS4, Paladins Xbox, Paladins Switch).