Realm Royale Game Service Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Apr 02, 2022 - 18:44 EDT
Monitoring
The live game services for #RealmRoyale have resumed. We will continue to monitor.
Posted Apr 02, 2022 - 17:53 EDT
Investigating
We are currently investigating an issue that is affecting live game services in #RealmRoyale.
Posted Apr 02, 2022 - 17:40 EDT
This incident affected: Realm Royale (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch).