Rogue Company Limited Logins
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Oct 03, 2020 - 04:17 EDT
Update
We are continuing to monitor for any further issues.
Posted Oct 03, 2020 - 02:56 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 03, 2020 - 02:01 EDT
Update
Logins have resumed for #RogueCompany
Posted Oct 03, 2020 - 01:48 EDT
Identified
#RogueCompany will be coming down for maintenance shortly.
Posted Oct 03, 2020 - 00:46 EDT
Update
Logins for #RogueCompany have resumed.
Posted Oct 02, 2020 - 23:23 EDT
Update
Logins for #RogueCompany have been limited again temporarily.
Posted Oct 02, 2020 - 23:05 EDT
Update
Logins for #RogueCompany have resumed.
Posted Oct 02, 2020 - 22:49 EDT
Update
Logins for #RogueCompany have been limited again temporarily.
Posted Oct 02, 2020 - 22:38 EDT
Update
Logins for #RogueCompany have resumed.
Posted Oct 02, 2020 - 21:44 EDT
Update
Logins for #RogueCompany have been limited again temporarily.
Posted Oct 02, 2020 - 21:18 EDT
Update
Logins for #RogueCompany have resumed.
Posted Oct 02, 2020 - 19:59 EDT
Update
Logins for #RogueCompany have been limited again temporarily.
Posted Oct 02, 2020 - 19:18 EDT
Update
Logins for #RogueCompany have resumed.
Posted Oct 02, 2020 - 18:49 EDT
Update
Logins for #RogueCompany have been limited again temporarily. Thank you for your patience.
Posted Oct 02, 2020 - 18:29 EDT
Monitoring
Logins for #RogueCompany have resumed. We will continue to monitor the results for any further issues.
Posted Oct 02, 2020 - 17:11 EDT
Investigating
Logins for #RogueCompany have been limited temporarily to address issues with the game's live services. We will update our progress accordingly.
Posted Oct 02, 2020 - 16:20 EDT
This incident affected: Rogue Company (Rogue Company PC, Rogue Company PS4, Rogue Company Xbox, Rogue Company Switch, Rogue Company Epic).