Smite Blitz Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Mar 10, 2020 - 13:40 EDT
Investigating
We are aware of an issue that is preventing some players from logging into their respective servers on Smite Blitz, and we are investigating the issue.
Posted Mar 06, 2020 - 18:09 EST
This incident affected: SMITE Blitz (SMITE Blitz Mobile).