Smite Xbox Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Smite #Xbox issue has been resolved.
Posted 3 months ago. Aug 07, 2018 - 14:34 EDT
Monitoring
#Smite #Xbox is back up. We are monitoring the results.
Posted 3 months ago. Aug 07, 2018 - 14:00 EDT
Identified
We are performing an emergency restart for #Smite #Xbox to address an issue. Game will be back up soon.
Posted 3 months ago. Aug 07, 2018 - 13:53 EDT
This incident affected: Smite (Smite Xbox).