Smite Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted May 18, 2023 - 10:50 EDT
Monitoring
#SMITE logins have resumed. We will continue to monitor
Posted May 18, 2023 - 10:38 EDT
Investigating
We are investigating an issue that is affecting player logins for #SMITE
Posted May 18, 2023 - 10:03 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic).