Smite Matchmaking Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Sep 24, 2021 - 23:58 EDT
Monitoring
Logins and matchmaking services have resumed for #SMITE.
Posted Sep 24, 2021 - 22:30 EDT
Identified
We are aware of an issue affecting #SMITE matchmaking services. We are working to correct the issue. Logins have been limited in the meantime.
Posted Sep 24, 2021 - 22:25 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic).