Paladins Switch Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Nintendo services are currently undergoing maintenance.
Posted 29 days ago. Aug 27, 2018 - 16:07 EDT
Investigating
We are currently investigating an issue that is affecting Paladins Switch.
Posted 29 days ago. Aug 27, 2018 - 16:03 EDT
This incident affected: Paladins (Paladins Switch).