Paladins Server Maintenance
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Paladins server maintenance has been completed!
Posted Apr 04, 2023 - 16:44 EDT
Identified
We are performing a server maintenance on #Paladins at this time. The game will be back shortly, and we apologize for the inconvenience.
Posted Apr 04, 2023 - 15:37 EDT
This incident affected: Paladins (Paladins PC, Paladins PS4, Paladins Xbox, Paladins Switch, Paladins Epic).