Xbox products difficulty logging in
Incident Report for Hi-Rez Studios, Inc
Resolved
#Xbox services are reporting that they are fully functional. If you are still having difficulty logging in, then a full reboot of your #Xbox should help. https://support.xbox.com/en-US/xbox-live-status
Posted Aug 15, 2018 - 23:20 EDT
Update
We are seeing an increase in #Xbox users that are able to log in to our products, but many are still experiencing difficulties. We are continuing to monitor. https://support.xbox.com/en-US/xbox-live-status
Posted Aug 15, 2018 - 22:57 EDT
Update
We are continuing to monitor for any further issues.
Posted Aug 15, 2018 - 21:31 EDT
Monitoring
#Xbox Live is having issues, and as such, users of our #Xbox products could encounter difficulty logging in. We are continuing to monitor the situation. https://support.xbox.com/en-US/xbox-live-status
Posted Aug 15, 2018 - 21:31 EDT
This incident affected: SMITE (SMITE Xbox) and Paladins (Paladins Xbox).