Realm Royale Discord Client Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This #RealmRoyale Discord client issue has been resolved.
Posted Jun 20, 2019 - 09:45 EDT
Identified
We are currently working on resolving an issue with the #RealmRoyale Discord client.
Posted Jun 20, 2019 - 08:46 EDT
This incident affected: Realm Royale Reforged (Realm Royale PC).