Realm Royale Crossplay Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This #RealmRoyale incident has been resolved.
Posted Nov 18, 2020 - 09:39 EST
Monitoring
The emergency restart has been completed for #RealmRoyale #PC, #PS4, #Switch, & #Xbox. We are monitoring the results at this time.
Posted Nov 18, 2020 - 09:07 EST
Identified
We are performing an emergency restart on #RealmRoyale #PC, #PS4, #Switch, & #Xbox.
Posted Nov 18, 2020 - 08:48 EST
This incident affected: Realm Royale (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch).