Hirez Games Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted May 03, 2020 - 05:58 EDT
Investigating
Automated services have detected a possible discovery issue that may impact multiple games. We are investigating. #SMITE #Paladins
Posted May 02, 2020 - 21:11 EDT