Rogue Company Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Aug 14, 2020 - 04:34 EDT
Monitoring
The restart is now complete, and logins have resumed. We will be monitoring the results.
Posted Aug 14, 2020 - 00:06 EDT
Identified
We are performing a restart of #RogueCompany; the game will be back shortly.
Posted Aug 13, 2020 - 23:09 EDT
Investigating
We are currently investigating an issue that is impacting live services for #RogueCompany
Posted Aug 13, 2020 - 22:27 EDT
This incident affected: Rogue Company (Rogue Company PC, Rogue Company PS4, Rogue Company Xbox, Rogue Company Switch, Rogue Company Epic).