PlayStations Network Login Issues.
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Apr 27, 2021 - 18:48 EDT
Monitoring
PlayStation Network is still reporting issues with their network.
Posted Apr 27, 2021 - 18:28 EDT
Investigating
PlayStation is reporting issues for all PSN players in all our games #PSN #SMITE #Paladins #RealmRoyale #RogueCompany. We are monitoring and will update.
Posted Apr 27, 2021 - 17:20 EDT
This incident affected: SMITE (SMITE PS4), Paladins (Paladins PS4), Realm Royale Reforged (Realm Royale PS4), and Rogue Company (Rogue Company PS4).