Realm Royale Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
Restart of Realm Royale has been completed
Posted Dec 04, 2019 - 15:08 EST
Investigating
We are performing an emergency restart for Realm Royale
Posted Dec 04, 2019 - 14:40 EST
This incident affected: Realm Royale (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch).