Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Apr 09, 2018 - 07:13 EDT
Monitoring
We are recovering.
Posted Apr 09, 2018 - 06:20 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted Apr 09, 2018 - 06:00 EDT
This incident affected: Paladins (Paladins PC).