Realm Royale Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 9 days ago. Aug 06, 2018 - 21:15 EDT
Monitoring
Steam services seem to be operational, we are continuing to monitor the situation.
Posted 9 days ago. Aug 06, 2018 - 20:35 EDT
Investigating
There is an issue with Steam services that is affecting logins for players on Realm Royale.
Posted 9 days ago. Aug 06, 2018 - 20:05 EDT
This incident affected: Realm Royale (Realm Royale PC).