Paladins PC Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
The #Paladins#PC emergency restart has been completed. We are monitoring the results.
Posted 13 days ago. Aug 03, 2018 - 03:15 EDT
Investigating
We are performing an emergency restart for #Paladins #PC. Game will be back up soon.
Posted 13 days ago. Aug 03, 2018 - 02:44 EDT
This incident affected: Paladins (Paladins PC).