Realm Royale Xbox Issue.
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Oct 08, 2019 - 17:30 EDT
Investigating
We are currently experiencing issues with #RealmRoyale for #Xbox.
Posted Oct 08, 2019 - 12:12 EDT
This incident affected: Realm Royale (Realm Royale Xbox).