Paladins Crossplay Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Mar 24, 2019 - 19:03 EDT
Monitoring
The restart is now finished, and the game is back online. We will be monitoring the results in the mean time.
Posted Mar 24, 2019 - 18:01 EDT
Identified
We are performing an emergency restart of #Paladins #PC #XBOX and #Switch to address an issue with logins. The game will be back shortly.
Posted Mar 24, 2019 - 17:49 EDT
This incident affected: Paladins (Paladins PC, Paladins Xbox, Paladins Switch).