Rogue Company Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Aug 12, 2022 - 21:57 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 12, 2022 - 19:49 EDT
Update
We are continuing to investigate this issue.
Posted Aug 12, 2022 - 19:27 EDT
Investigating
We are currently investigating this issue.
Posted Aug 12, 2022 - 19:26 EDT
This incident affected: Rogue Company (Rogue Company PC, Rogue Company PS4, Rogue Company Xbox, Rogue Company Switch, Rogue Company Epic).