Smite Matchmaking Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Jun 04, 2022 - 22:40 EDT
Update
We are continuing to monitor for any further issues.
Posted Jun 04, 2022 - 18:57 EDT
Monitoring
Logins and matchmaking have resumed for #SMITE. Players may experience longer wait times than normal for the next 30 minutes or so. Ranked queues will also unavailable during this time. Thank you for your patience.
Posted Jun 04, 2022 - 16:51 EDT
Investigating
We are investigating an issue that is affecting matchmaking for #SMITE. Logins have been limited while we work through this issue.
Posted Jun 04, 2022 - 16:33 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic).