Smite Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Mar 21, 2020 - 23:44 EDT
Monitoring
Logins have resumed. We will be monitoring the results.
Posted Mar 21, 2020 - 22:41 EDT
Investigating
We are investigating an issue that is affecting logins for Smite. Players may be unable to login in the meantime.
Posted Mar 21, 2020 - 22:22 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch).