Smite Live Service Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Mar 26, 2020 - 19:04 EDT
Monitoring
The restart is complete. Players should now be able to log in. We will be monitoring the results.
Posted Mar 26, 2020 - 18:06 EDT
Identified
We will be performing an emergency restart of Smite. The game will be back shortly.
Posted Mar 26, 2020 - 17:47 EDT
Investigating
We are investigating an issue that is affecting Smite live services.
Posted Mar 26, 2020 - 17:43 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch).