Paladins Crossplay Server Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue has ben identified for #Paladins, we apologize the inconvenience this has caused.
Posted Nov 03, 2020 - 07:26 EST
Investigating
We are currently investigating this issue.
Posted Nov 03, 2020 - 07:19 EST
This incident affected: Paladins (Paladins PC, Paladins PS4, Paladins Xbox, Paladins Switch, Paladins Epic).