Smite PS4 Logins
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 month ago. Jun 07, 2019 - 22:22 EDT
Identified
We are currently working to resolve an issue that is affecting logins for Smite PS4.
Posted about 1 month ago. Jun 07, 2019 - 22:14 EDT
This incident affected: Smite (Smite PS4).