Divine Knockout 0.20 Maintenance
Incident Report for Hi-Rez Studios, Inc
Resolved
The #DivineKnockout 0.20 Upgrade has been completed!
Posted Jan 25, 2023 - 09:14 EST
Monitoring
We apologize for the inconvenience and confusion. #DivineKnockout is still under maintenance for the 0.20 Upgrade
Posted Jan 25, 2023 - 09:02 EST
This incident affected: Divine Knockout (Divine Knockout Steam, Divine Knockout PS4, Divine Knockout Xbox, Divine Knockout Epic).