Rogue Company Crossplay: Issues Joining Queue & Launching Matches
Incident Report for Hi-Rez Studios, Inc
Resolved
This issue with #RogueCompany #PC, #PS4, #Switch, & #Xbox has been resolved.
Posted Oct 20, 2020 - 12:47 EDT
Monitoring
We have implemented a solution, and we are closely monitoring the results. Logins for #RogueCompany #PC, #PS4, #Switch, & #Xbox have resumed at this time.
Posted Oct 20, 2020 - 12:26 EDT
Update
Logins have been limited at this time for #RogueCompany #PC, #PS4, #Switch, & #Xbox as we further our investigation
Posted Oct 20, 2020 - 12:04 EDT
Investigating
We are currently investigating issues with joining queues and launching matches for #RogueCompany #PC, #PS4, #Switch, & #Xbox
Posted Oct 20, 2020 - 12:03 EDT
This incident affected: Rogue Company (Rogue Company PC, Rogue Company PS4, Rogue Company Xbox, Rogue Company Switch, Rogue Company Epic).