Smite Crossplay Emergency Server Maintenance
Incident Report for Hi-Rez Studios, Inc
Resolved
The #Smite emergency server maintenance has been completed.
Posted Jul 08, 2021 - 16:01 EDT
Monitoring
This #Smite server maintenance has completed. We are monitoring the results at this time.
Posted Jul 08, 2021 - 13:50 EDT
Identified
We are performing an emergency server maintenance for #Smite crossplay. Logins are limited at this time, and the game will be coming down at 17:30 UTC. We apologize for the inconvenience and will update accordingly.
Posted Jul 08, 2021 - 13:24 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic).