Smite Xbox Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Smite #Xbox issue has been resolved.
Posted Nov 14, 2018 - 11:52 EST
Monitoring
The restart is complete, we are continuing to monitor.
Posted Nov 14, 2018 - 11:27 EST
Investigating
We are performing an emergency restart on #Smite #Xbox.
Posted Nov 14, 2018 - 11:12 EST
This incident affected: SMITE (SMITE Xbox).