Smite PC Matchmaking
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 07, 2018 - 00:31 EDT
Monitoring
We have resumed logins for #Smite #PC. We will continue to monitor the situation.
Posted 3 months ago. Jul 06, 2018 - 21:40 EDT
Identified
There is an issue with matchmaking on #Smite #PC. We have identified the issue, and will be temporarily pausing logins.
Posted 3 months ago. Jul 06, 2018 - 21:22 EDT
This incident affected: Smite (Smite PC).