Rogue Company Crossplay: Issues Launching Matches
Incident Report for Hi-Rez Studios, Inc
Resolved
This #RogueCompany #PC, #PS4, #Switch, & #Xbox issue has been resolved.
Posted Oct 20, 2020 - 10:54 EDT
Monitoring
We have implemented a fix for this issue affecting #RogueCompany #PC, #PS4, #Switch, and #Xbox, and we are monitoring the results.
Posted Oct 20, 2020 - 10:06 EDT
Investigating
We are currently investigating an issue with launching matches for #RogueCompany #PC, #PS4, #Switch, and #Xbox
Posted Oct 20, 2020 - 09:10 EDT
This incident affected: Rogue Company (Rogue Company PC, Rogue Company PS4, Rogue Company Xbox, Rogue Company Switch, Rogue Company Epic).