Realm Royale Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
Restart of #Realm Royale has been completed
Posted Mar 23, 2021 - 09:59 EDT
Investigating
We will be performing an emergency restart of #Realm Royale momentarily
Posted Mar 23, 2021 - 09:45 EDT
This incident affected: Realm Royale (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch).