Paladins Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Nov 02, 2019 - 21:46 EDT
Monitoring
Restart is complete, and the game is back up. We will be monitoring the results.
Posted Nov 02, 2019 - 20:33 EDT
Update
We will be performing an emergency restart of Paladins. The game will be back shortly.
Posted Nov 02, 2019 - 20:13 EDT
Identified
We are currently working to resolve an issue that is affecting game logins for Paladins.
Posted Nov 02, 2019 - 20:10 EDT
This incident affected: Paladins (Paladins PC, Paladins PS4, Paladins Xbox, Paladins Switch).