Smite Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Mar 20, 2020 - 21:24 EDT
Monitoring
Logins have resumed. We will continue to monitor the situation.
Posted Mar 20, 2020 - 21:02 EDT
Identified
We have identified an issue that is affecting logins for Smite. Players may be unable to login in the meantime
Posted Mar 20, 2020 - 20:42 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch).