Paladins PC Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This issue with #Paladins #PC has been resolved.
Posted 7 months ago. Jan 11, 2018 - 18:38 EST
Monitoring
The emergency restart of #Paladins #PC has been completed. We are monitoring the results.
Posted 7 months ago. Jan 11, 2018 - 18:14 EST
Identified
We are performing an emergency restart for #Paladins #PC. The game will be back up soon.
Posted 7 months ago. Jan 11, 2018 - 18:01 EST
Monitoring
The emergency restart of #Paladins #PC has been completed. We are monitoring the results.
Posted 7 months ago. Jan 11, 2018 - 17:24 EST
Identified
We are performing an emergency restart for #Paladins #PC. The game will be back up soon.
Posted 7 months ago. Jan 11, 2018 - 16:29 EST
This incident affected: Paladins (Paladins PC).