Paladins PC - Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 13 days ago. Sep 12, 2018 - 17:08 EDT
Monitoring
The #Paladins #PC emergency restart has been completed. We are monitoring the results.
Posted 13 days ago. Sep 12, 2018 - 16:46 EDT
Identified
We are performing an emergency restart for #Paladins #PC. We apologize for the inconvenience and will updated accordingly.
Posted 13 days ago. Sep 12, 2018 - 16:31 EDT
This incident affected: Paladins (Paladins PC).