Login Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
We have implemented a fix for the login issues affecting #SMITE, #Paladins, and #RealmRoyale. Logins have returned to normal; we will continue to monitor. Thank you all for your patience.
Posted Nov 18, 2021 - 17:13 EST
Update
Logins have resumed for #RealmRoyale. Players may still experience intermittent login issues.
Posted Nov 18, 2021 - 16:59 EST
Update
We are seeing this issue return to #SMITE, #Paladins, and #RealmRoyale. Players in #RealmRoyale may not be able to login at this time. Logins may continue to be intermittent until this issue is resolved. We apologize for the inconvenience.
Posted Nov 18, 2021 - 14:26 EST
Monitoring
#RealmRoyale logins have resumed. Logins for #SMITE and #Paladins are recovering as well. We are continuing to monitor.
Posted Nov 18, 2021 - 14:04 EST
Investigating
We are currently experiencing intermittent login issues across #SMITE, #Paladins, and #RealmRoyale. We are working to resolve this issue as soon as possible.
Posted Nov 18, 2021 - 13:43 EST
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic), Paladins (Paladins PC, Paladins PS4, Paladins Xbox, Paladins Switch, Paladins Epic), and Realm Royale Reforged (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch).