Rogue Company Limited Logins
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Oct 03, 2020 - 17:57 EDT
Monitoring
Logins for #RogueCompany have resumed. We will be monitoring the results for any further issues.
Posted Oct 03, 2020 - 15:02 EDT
Investigating
We are limiting logins for #RogueCompany to investigate issues with the live game services.
Posted Oct 03, 2020 - 14:40 EDT
This incident affected: Rogue Company (Rogue Company PC, Rogue Company PS4, Rogue Company Xbox, Rogue Company Switch, Rogue Company Epic).