Smite Matchmaking Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Mar 21, 2021 - 00:05 EDT
Monitoring
Logins and matchmaking have resumed for #Smite. We will continue to monitor.
Posted Mar 20, 2021 - 23:49 EDT
Update
Logins for #Smite have been limited temporarily to relieve stress on some of our live game services while we sort through this issue.
Posted Mar 20, 2021 - 23:39 EDT
Investigating
We are currently investigating an issue that is affecting logins and matchmaking for #Smite.
Posted Mar 20, 2021 - 23:35 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic).