Rogue Company Match Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Aug 25, 2021 - 22:12 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 25, 2021 - 22:02 EDT
Investigating
We are currently investigating.
Posted Aug 25, 2021 - 22:02 EDT
This incident affected: Rogue Company (Rogue Company PC, Rogue Company PS4, Rogue Company Xbox, Rogue Company Switch, Rogue Company Epic).